TechTip: DB2 Web Query and Excel Spreadsheets- Easy as Piel, Part |

Did you know DB2 Web Query has output options to send your reports directly to Excel? Learn about some
features that will help you easily and quickly build spreadsheets.

Written by Gene Cobb

The Excel spreadsheet is an immensely popular tool for analyzing business data. It has a vast array of features
and functions for manipulating and representing information in various ways to help you understand your
business data and make more informed decisions going forward. Consequently,many users and analysts go to
great lengths to extract data from their production database and copy it into Excel. If your business data
happens to be stored in a DB2 for i database, there's simply no easier way to push this information down to
Excel than by using IBM DB2 Web Query for i.

In this multi-part TechTip, you will learn about a number of DB2 Web Query features that you can use to make
those Excel reports look exactly like you want them to—with the click of the Run button!

Various Excel Output Formats

First let's talk about the different options you have when it comes to generating Excel output. The report
development tool for DB2 Web Query is a tool called InfoAssist. With InfoAssist, you can also create charts,
dashboards, and compound documents, but this article will focus on generating reports that go to Excel output
format.

The format tab of InfoAssist shows you the various output types. If you click on the down arrow in the Excel
icon, you will see a list of Excel output format options you can choose from. See Figure 1: Choose your Excel
output format.
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Figure 1: Choose your Excel output format.

An explanation of each output type is provided below:
e Excel—Generates a spreadsheet in the .XLS format
e Excel 2007—Generates a spreadsheet in the . XLSX format
e Excel Formula—Generates a spreadsheet in the .XLS format. Cells that contain values that were
calculated during report execution time (those based on define fields, compute fields, subtotals, and
totals) will have the appropriate Excel formula, not the value itself.
o Excel Pivot—Generates a spreadsheet in the .XLS format with pivot table processing

For our report, we want to generate Excel 2007 (XLSX) output, so that output type is selected. For the report
layout, we would like to query the ORDERS table in our DB2 for i database and sort by the Product Type,
Product Category, and Product Name columns. For the report measure, we would like to show the Quantity
sold. From InfoAssist, our example report definition is shown in Figure 2: Your report definition.
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Figure 2: Your report definition is set.

Before saving the report, click the Run button to make sure it looks the way you want. The results are shown in
Figure 3: Are the report results.

Product Mame
2 |Audio Amplifiers/PreAmps/Tuners  AM / FM Stereo Tuner 4,778
3 Modular Compaonents Series Preamp 5.1 15,981
4 P4a4000 Stereo & Surround Power Amplifier 15,272
5 Power Amplifier 24,565
6 PreAmp/Tuner Two 48,826
T Audio Systems Home Theater Surround System 8,893
8 Home Theater 5.1 System 37,856
9 Home Theater 7.1 THX System 8,103
10 Micro HiFi Stereo System 20,663
11 Micro 5.1 System 10,505
12 CD Players and Recorders CD Changer / CD Player 23,563
13 CD Recorder with 50GE Hard Disc Drive 7,245
14 Digital CD Turntable 42,442
15 Multichannel Super Audio CD Player 4,782
16 400 Disc Super Audio CD Changer 4,609
17 MP3 MP3 Digital Audio Computer 11,713
18 MP3 Digital Audio Computer 10GE 9,350
19 MP3 Digital Audio Computer 4GB 44 541
20 MP3 Player 119,246
21 MP3 Player Julebox Hard Drive 31,192
22 Receivers Audio/Video Receiver 21,622
23 5.1 Channel Home Theater Receiver 100 WPC 10,803
24 5.1 Channel Home Theater Receiver 150 WPC 7,249
25 .1 Channel Home Theater Receiver 100 WPC 40,573
26 7.1 Channel THX Home Theater Receiver 7,130

Figure 3: Are the report results what you want them to be?



Repeat Sort Values
By default, DB2 Web Query does not show repeating sort values in a Summary report. This is not always ideal
for spreadsheet output. In many cases, spreadsheet users like to show every value in all rows and columns.
This default behavior is easily remedied by a feature called (strangely enough) Repeat Sort Values. As shown
in Figure 4: Select Format > Features to get Repeat Sort Values, this feature is found by selecting the Format
tab and expanding the Features group.
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Figure 4: Select Format > Features to get Repeat Sort Values functionality.

As you can see in Figure 5: Repeated Sort Values, running the report reveals that all values for the Product
Type, Product Category, and Product Name columns are shown in the spreadsheet.
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Figure 5: Repeated Sort Values shows values in all columns.
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Sort Across

The report is looking good but is far from finished. We would also like a breakdown of the countries in which we
sold our products. But rather than including the Country database field as a sort by (where the data for each
unique country is shown as a row in the report), we would like to show the country data in report columns. This
technique of pivoting the data means we can see the numbers for the various countries side by side. This is
accomplished by selecting Country as an Across field in our report and is shown in Error! Reference source
not found..
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i
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Figure 6: The report definition now includes Across.

Figure 7: These are the report results with Across shows the results of running this report.

Figure 7: These are the report results with Across.

Stack Measures

As you can see, sort Across is a very useful feature because you can juxtapose the measure columns and do
easier side-by-side comparisons of the numbers. However, it increases the number of measure columns in the

A B c D E F G H
1 Country
b Canada France Germany Spain United States
3 Product Name
4 | Audio Amplifiers/PreAmps/Tuners  AM [/ FM Stereo Tuner 339 n 302 218 3,548
5 | Audio Amplifiers/PreAmps/Tuners  Modular Components Series Preamp 5.1 1,953 904 L] 502 11,822
6 |Audio Amplifiers/PreAmps/Tuners PA4000 Stereo & Surround Power Amplifier 1,780 528 715 385 11,864
7 | Audio Amplifiers/PreAmps/Tuners  Power Amplifier 3,220 1,058 1,251 1,159 17,877
8 Audio Amplifiers/PreAmps/Tuners PreAmp/Tuner Two 5,763 2,100 3,074 2,836 35,063
9 | Audio Audio Systems Home Theater Surround System 782 118 200 269 7,524
10 |Audia Audio Systems Home Theater 5.1 System 4,879 1,963 2,357 1,513 27,144
11 | Audio Audio Systems Home Theater 7.1 THX System 1,110 385 430 569 5,609
12 | Audio Audio Systems Micro HiFi Stereo System 2,199 1,273 516 739 15,936
13 | Audio Audio Systems Micro 5.1 System 786 410 134 260 8,915
14 | Audio CD Players and Recorders CD Changer / CD Player 2,239 1,708 Bed 653 18,09%
15 | Audio CD Players and Recorders CD Recorder with 50GB Hard Disc Drive 1,393 147 13 203 5,489
16 |Audio CD Players and Recorders Digital CD Turntable 4,758 1,581 2,097 2,694 31,312
17 | Audio CD Players and Recorders Multichannel Super Audio CD Player 278 171 219 &6 4,048
18 |Audio CD Players and Recorders 400 Disc Super Audio CD Changer 178 218 R 76 4,137
19 | Audio MP3 MP3 Digital Audio Computer 1,633 547 561 414 8,558
20 |Audio MP3 MP3 Digital Audio Computer 10GE 534 7 819 339 7,381
21 | Audio MP3 MP3 Digital Audio Computer 4GB 4,558 3,529 2,672 1,764 32,018
22 | Audio MP3 MP3 Player 13,916 5,133 6,987 4,647 88,563
23 |Audio MP3 MP3 Player Julebox Hard Drive 4,161 986 832 1,332 23,881
24 | Audio Receivers Audio/Video Receiver 2,106 699 1,302 2,045 15,470
25 |Audio Receivers 5.1 Channel Home Theater Receiver 100 WPC 708 656 206 511 B,722
26 |Audio Receivers 5.1 Channel Home Theater Receiver 150 WPC 945 305 335 37 5,627
27 |Audio Receivers 6.1 Channel Home Theater Receiver 100 WPC 4,311 1,570 3,212 1,570 29,900
28 | Audio Receivers 7.1 Channel THX Home Theater Receiver 925 252 B& 99 5,768



report by a factor of the number of unique sort across values. Since there is only one measure column, this is
not really an issue in the current version of our report. But consider what happens when you add four more
measure columns to the report as shown in Figure 8: The report definition now includes more measure
columns.
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Figure 8: The report definition now includes more measure columns.

The report now has five measure columns. Because our Orders table has five unique values for Country, this
means that the report will have 25 (5 x 5) measure columns! As you can see in Figure 9: With this many
columns, when this report is run, the report is immensely wider and much more difficult to view and
comprehend.

Figure 9: With this many columns, the report results are hard to read.

What to do, what to do? This report has the information that's needed; you really don't want to remove any of it,
but it's quite overwhelming and hard to digest. Never fear! Reports that have multiple measures and Across
fields are great candidates for an InfoAssist feature called Stack Measures. This option also performs a pivot of
the data—only now the measures are stacked so that they're shown vertically. This can really tidy up these
wide reports!

To stack the measures in the report, go to the Format tab, expand the Features group, and select the Stack
Measure icon. Once the icon is illuminated, the feature is activated.
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Figure 10: Turn on the Stack Measures feature.
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Now that the measures are displayed in vertical columns, the report becomes longer (vertically), but it's much
easier to read and comprehend.
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E
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31
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187
§779,247.00
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1,780

172
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a1
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$6,342,700.00
53,410,421

Figure 11: Report results with stacked measures are easier to read.
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537,100.00
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89
5360,696.00
$298,320.00
562,376

528
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§157,872.00
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541,712
1,058

102
5263,442.00
5130,440.00
573,002
2,100
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$1,047,200.00
§525,000.00
§522,300
118

1"
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Germany
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29
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800
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5319,200.00
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715
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20
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218

20
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9
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385

3%
§115,115.00
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$30,415
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10
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2,83
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§1,413,164.00
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25
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1,513
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|
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3,548

344
5706,052.00
5354,800.00
5351,252
11,822

1,210
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5815,718
11,864

1,237
53,547,336.00
52,610,080.00
5937256
17,877

2,001
54,451,373.00
53,217,860.00
51,233,513
35,053
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58,763,250.00
S8,728,197
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738
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55,643,000.00
$1,873,476
27,144

2,922
$54,260,856.00
535,287,200.00
518,373,656

DB2 Web Query comes shipped with a large number of style sheets that can be used to customize the color,
font, size, borders, background colors, and other attributes. You can select one of these style sheets by
changing the theme of the report. The selected theme will be applied to the Excel spreadsheet. To change the
theme, select the Home tab, expand the Reports group, and click the Theme icon as shown in Figure 12:
Change the report's theme.
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Figure 12: Change the report's theme.

%

Theme

=

ks



A dialogue window with all of the provided DB2 Web Query themes is presented. Select a theme and click
Open. As shown in Figure 13: Select a theme, for our example, we select the ENBlue_DarkComp.sty theme.

e

Mame Size | Type Last Modified Title

@ EMBlack_Dark.sty 5.70KB sty October 02, 2012 ... ENBlack_Dark.sty

@ EMEBladk_DarkComp.sty 5.75KB sty October 02, 2012 ... ENBlack_DarkComp.sty
GE ENBlack_LightL.sty 5.47KB sty October 02, 2012 ... EMBlack_Light1.sty

GE ENBlack_Light2.sty 5.91KB sty October 02, 2012... ENBlack_Light2.sty

@ EMEBladk_Medium1.sty 5.87KB sty October 02, 2012 ... ENBlack_Medium1.sty
@ EMBlack_Medium?2.sty 5.85KB sty October 02, 2012 ... EMBlack_Medium2. sty =
@ EMblack_theme.sty 5.59 KB sty Qctober 02, 2012 ... ENblack_theme, sty

@ EmMbladkbluepurple. sty 11.66 KB sty October 02, 2012 ... ENblackbluepurple.sty
@ EMblue-medium. sty 20.29KB sty October 02, 2012 ... EMblue-medium, sty

@ EMBlue_Dark. sty 5.42KB sty Qctober 02, 2012 ... EMBlue_Dark.sty

@ EMElue_DarkComp.sty 5.53KB sty October 02, 2012 ... ENBlue_DarkComp.sty
@ EMBlue_Light1.sty 5.57KB sty October 02, 2012 ... ENBlue_Light1.sty

@ EMElue_Light2.sty 5.94KB sty October 02, 2012 ... ENBlue_Light2.sty

@ EMEBlue_Medium 1.5ty 5.90KB sty October 02, 2012 ... ENBlue_Medium1.sty
@ EMBlue_Medium2. sty 6.08 KB sty October 02, 2012 ... ENBlue_Medium2. sty
@ EMblue_theme.sty 7.92KB sty October 02, 2012 ... ENblue_theme.sty

@ EMcharcoal_theme. sty 3.14KB sty October 02, 2012 ... ENcharcoal_theme.sty
@ EMgolden. sty 11.69KE sty October 02, 2012 ... ENgolden.sty

@ EmMgradient_combine. sty 23.39KB sty October 02, 2012 ... EMgradient_combine. sty
@ EmMgray-ight.sty 11,68 KB sty October 02, 2012 ... EMaray-ight.sty

BZ ENarav theme.stv 8.20KE stv QOctober 02, 2012 ... EMarav theme.stv

|

File name:

Figure 13: Select a theme.

As you can see in Figure 14: The report results show the new theme, running the reports shows that the theme

EMBlue_DarkComp.sty

is applied to the generated spreadsheet.
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2 United States
KM Product Type  Product Category Product Name

LB Audio Amplifiers/PreAmps/Tuners  AM / FM Stereo Tuner

5

6 67,461.00
T

]

9 Amplifiers/PreAmps/Tuners  Modular Com

10

1

12

13

14 Amplifiers/PreAmps/ s PA4000 Stereo & Surround Power Amplifier

15

16 . $157,872.00
17 Cost of Goods Sold . 5116,160.00
18 Profit 5140,62 541,712
19 Amplifiers/PreAmps/Tuners  Power Amplifier Quantity

20 Returns

2 Revenue

22 Cost of Goods Sold

23 Profit

24 Amplifiers/PreAmps/’ PreAmp/Tuner Two Quantity

25 Returns

26 Revenue 52,875,737.00 51,047,900.00
27 Cost of Goods Sold $1,440,750.00 §525,000.00
28 Profit 1 B7 §522,900

29 Audio Systems Home Theater Surround Syste Quantity
30 Returns
H Revenue

32 Cost of Goods Sold 55 588,500.00
33 Profit 51 549,800

Figure 14: The report results show the new theme.

In fact, as a report developer, you can select a default theme for all report definitions that you create. This will
eliminate the need to select your preferred theme for every report you create. To change the default theme,
click on the |A icon at the top left of the tool bar and click the Options button. At the Options dialog window,
click the Browse button next to Document Theme. This is demonstrated in Figure 15: Change the default
theme..
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Figure 15: Change the default theme.

You can select your default theme from the same list of style sheets.

Got DB2 Web Query?

If you don't have DB2 Web Query and aren't sure how you can get it, work with your IBM representative or
authorized Business Partner to obtain the software. If you own Query/400 but were never shipped the Version



1 DB2 Web Query product, and are at V6R1 or higher OS level, you can order the Express Edition of DB2 Web
Query at no charge. This will give you the entry-level package (which includes InfoAssist and all the features
covered in this article) as well as features such Active Reports, OLAP, and DB2 Web Query mobile support.
You can also download a 70-day trial of Version 2 from the IBM ESS Web site. Refer to the FAQ document at
www.ibm.com/systems/i/db2/webquery for details.

Summary

DB2 Web Query has many features and shortcuts that you can use to easily generate Excel spreadsheet the
way you want them. In fact, this is only part one of a three-part article on DB2 Web Query tips for Excel. In my
next TechTip, I'll show you how DB2 Web Query features like Table of Contents, Compound Documents, Excel
with Formula, and Pivot Tables can be used to achieve your Excel reporting requirements.



